當前位置:首頁 » 網頁前端 » openwrtweb服務
擴展閱讀
硬碟通電壽命 2022-07-02 00:32:20
固態硬碟4k對齊工具 2022-07-02 00:31:11

openwrtweb服務

發布時間: 2022-05-19 16:03:08

Ⅰ openwrt怎麼啟用web界面

tp 的941n刷完openwrt,怎麼安裝web管理界面
首先,用ssh登錄路由(可用putty等軟體)。確保路由連上網。——————————配置PPPOE上網————————————參考:openwrt命令行配置PPPOE上網的方法:1.vi /etc/config/network(編輯network網路配置文件)2.如果無法編輯,按a進入編輯模式。3.輸入以下內容:config 'interface' 'wan'option ifname 'wan'option proto 'pppoe'option username 'xxxxxxx' (xxxxxxx表示是你的pppoe帳號)option password 'xxxxxx' (xxxxxx表示是你的密碼)option peerdns '1'option defaultroute '1'4.按:(冒號)退出編輯模式,再輸入x,然後回車,保存文件。5.輸入 /etc/init.d/network start 並回車。配置PPPOE上網完畢。——————————配置PPPOE上網————————————輸入opkg update 並回車。(更新軟體包列表)輸入opkg install luci 並回車。(安裝Web管理軟體luci)待完成,輸入/etc/init.d/uhttpd start 並回車。(啟動Web服務)輸入/etc/init.d/uhttpd enable 並回車。(設為開機自動啟動)好了,完成,可以通過瀏覽器訪問你的路由器並進行配置了。補充一下:如果你需要中文界面,可以opkg install luci-i18n-chinese安裝中文語言包。

Ⅱ 路由器刷了openwrt,用winscp能進去,但是登陸不上WEB管理頁面,怎麼回事

你刷的是什麼版本的op啊?
是不是固件包沒有包含luci啊?
putty登錄用命令:opkg list_installed
看看是否有luci包

如果你是從http://downloads.openwrt.org/上直接下載的固件,只有基本系統的

試試用winscp上傳luci或者將wan口接外網,用opkg升級luci
putty登錄
opkg update
opkg luci

Ⅲ 如何利用openwrt的web配置界面來配置埠映射

/etc/config/firewall
修改完以後請在終端窗口輸入 /etc/init.d/firewall restart來重啟防火牆使設置生效

埠映射:來自internet的使用tcp協議訪問路由80埠的請求映射到內網192.168.1.10的 80埠
可以映射埠提高P2P效率
config redirect
option src wan
option src_dport 80
option proto tcp
option dest_ip 192.168.1.10

重定向:區域網訪問10.55.34.85的請求將被重定向到63.240.161.99的123埠
可以用來做網頁重定向等通告功能
config redirect
option src lan
option dest wan
option src_ip 10.55.34.85
option src_dip 63.240.161.99
option dest_port 123
option target SNAT

訪問控制:攔截區域網到 123.45.67.89的訪問請求
可以用來過濾某些網站
config rule
option src lan
option dest wan
option dest_ip 123.45.67.89
option target REJECT

基於MAC的訪問控制,攔截區域網內MAC為 00:00:00:00:00的機子訪問互聯網
config rule
option src lan
option dest wan
option src_mac 00:00:00:00:00
option target REJECT

設置DMZ:
config redirect
option src wan
option proto all
option dest_ip 192.168.1.2

Ⅳ 求助openwrt掛網web環境的搭建

opkg updateopkg install php5 php5-mod-gd php5-mod-session php5-mod-pdo php5-mod-pdo-mysql php5-mod-mysql php5-mod-mcrypt php5-mod-mbstring php5-fastcgi php5-cgi php5-mod-xml php5-mod-ctype php5-mod-curl php5-mod-exif php5-mod-ftp php5-mod-iconv php5-mod-json php5-mod-sockets php5-mod-sqlite3 php5-mod-tokenizer php5-mod-zipopkg install mysql-server opkg install nginx spawn-fcgi zoneinfo-core zoneinfo-asiaopkg install shadow-groupadd shadow-useraddgroupadd wwwuseradd -g www wwwchown -R www:www /mn t/sda1/web修改/etc/my.cnf
datadir = /mnt/sda1/data/mysql/

tmpdir = /mnt/sda1/data/tmp/

創建資料庫文件夾
mkdir -p /mnt/sda1/data /mnt/sda1/data/mysql /mnt/sda1/data/tmp

創建默認的資料庫
/usr/bin/mysql_install_db --force

啟動mysql
/etc/init.d/mysqld start

輸入如下命令創建mysql的密碼
/usr/bin/mysqladmin -u root password 123456

登陸資料庫
mysql -u root -p

連接上mysql之後,創建資料庫(可以自己定義,記住就行了,之後會用到)
create database abcd
\g

查看當前可用資料庫
show databases
\g

退出mysqlquit修改/etc/nginx/nginx.conf
user www www;
worker_processes 1;
pid /var/run/nginx.pid;
error_log /var/log/nginx_error.log;
events {
use epoll;
worker_connections 1024;
}

http {
include mime.types;
default_type application/octet-stream;
sendfile on;
tcp_nopush on;
#keepalive_timeout 0;
keepalive_timeout 65;
gzip on;
access_log off;

include vhost.conf;
}

修改/etc/nginx/fastcgi_params,解決Nginx文件類型錯誤解析漏洞
if ($request_filename ~* (.*)\.php) {
set $php_url $1;
}
if (!-e $php_url.php) {
return 403;
}

fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;

fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;

fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE nginx/$nginx_version;

fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fas

Ⅳ 請教openwrt遠程web管理設置問題

里兩個路由器,一級路由器a192.168.10.1,路由器a的DMZ指向二級路由器b192.168.10.2,在路由器a動態DNS邦定動態IP,二級路由器關掉DHCP,電腦連接二級路由器可以上網,二級路由器系統是openwrt,之前二級路由器系統是DDWRT的,直接開遠程訪問就可以在公網訪問二級路由器,現在換openwrt系統了,怎麼弄也不行,我知道是openwrt設置出問題了,哪位高手知道的請指教一下,感激不盡。我的openwrt系統是luci的web管理介面,本人小菜不懂的用命令
補充一下,二級路由是經過LAN介面跟一級路由器連接的,關掉二級路由器的DHCP伺服器,

Ⅵ openwrt可以安裝web伺服器嗎

可以的。
openwrt的web配置界面,就是web伺服器提供的。
默認是安裝的 uhttpd 伺服器。如果空間足夠,可以安裝其它的web伺服器。
也可以安裝 python ,php,perl等腳本的支持。

Ⅶ 求助openwrt如何實現外網ip訪問web

可以用路由器的埠映射功能解決
1、登錄路由控制面板----轉發規則----埠轉發----啟用埠轉發

2、增加轉發規則,填寫完具體規則後應用

Ⅷ openwrt沒有web管理界面

在 OpenWrt源碼中,將 LuCI 配置進去即可。
首先進入OpenWrt源碼頂層目錄,然後運行 make menuconfig 命令。然後在彈出的配置界面中,我們首先進入 LuCI,然後進入 Collections,最後,將 luci 配置進系統(按空格鍵選擇)。
OpenWrt可以被描述為一個嵌入式的 Linux 發行版,(主流路由器固件有 dd-wrt,tomato,openwrt三類)而不是試圖建立一個單一的、靜態的系統。OpenWrt的包管理提供了一個完全可寫的文件系統,從應用程序供應商提供的選擇和配置,並允許您自定義的設備,以適應任何應用程序。

Ⅸ 如何將openwrt的wifi web認證模塊 安裝到Linux系統上

openwrt中集成了uhttp和LUCI作為web服務作為圖形配置界面,uhttpd是一個輕量級的web伺服器,而luci是用Lua這種輕量級的腳本語音寫的,性能比較優秀。具體的操作可以去wifidog.pro網站上去看看。