當前位置:首頁 » 文件傳輸 » 易語言訪問ftp圖片
擴展閱讀
如何查看applepay的密碼 2022-08-20 03:57:57

易語言訪問ftp圖片

發布時間: 2022-07-06 20:17:51

『壹』 易語言 ftp的操作

.版本 2
.支持庫 iext
.支持庫 internet.局部變數 項目類型, 整數型
.局部變數 選中項, 整數型
.局部變數 當前目錄, 文本型
.局部變數 容器1, 整數型選中項 = 遠程文件框.現行選中項
.如果真 (選中項 = -1)
返回 ()
.如果真結束
項目類型 = 遠程文件框.取表項數值 (選中項)當前目錄 = FTP取現行目錄 ()
.判斷開始 (項目類型 = 0) ' 是否為到上目錄
容器1 = 倒找文本 (當前目錄, 「/」, , 真)
.如果真 (容器1 ≠ -1)
當前目錄 = 取文本左邊 (當前目錄, 容器1)
.如果真 (當前目錄 ≠ 「/」)
當前目錄 = 取文本左邊 (當前目錄, 容器1 - 1)
.如果真結束
FTP置現行目錄 (當前目錄)
填充遠程框 ()
.如果真結束.判斷 (項目類型 = 1) ' 是否到子目錄
.如果真 (取文本右邊 (當前目錄, 1) ≠ 「/」)
當前目錄 = 當前目錄 + 「/」
.如果真結束
FTP置現行目錄 (當前目錄 + 遠程文件框.取標題 (選中項, ))
填充遠程框 ()
.默認.版本 2
.支持庫 iext
.支持庫 internet.子程序 填充遠程框
.局部變數 文件名, 文本型, , "0"
.局部變數 文件尺寸, 整數型, , "0"
.局部變數 文件屬性, 整數型, , "0"
.局部變數 文件時間, 日期時間型, , "0"
.局部變數 數目, 整數型
.局部變數 容器1, 整數型
.局部變數 名稱, 文本型
.局部變數 索引, 整數型
.局部變數 現行目錄, 文本型遠程文件框.全部刪除 ()狀態標簽.標題 = 「正在獲取目錄列表,請稍候...」
狀態標簽.刷新顯示 () ' 立即顯示改變後的標題
數目 = FTP目錄列表 (「*.*」, , 文件名, 文件屬性, 文件尺寸, 文件時間)
' 填充目錄
現行目錄 = FTP取現行目錄 ()
.如果真 (現行目錄 ≠ 「/」)
遠程文件框.插入表項 (, , 0, , , 0) ' 如果不是根目錄,則插入到父目錄的特殊表項
.如果真結束.計次循環首 (數目, 容器1)
.如果真 (位與 (文件屬性 [容器1], #子目錄) ≠ 0)
名稱 = 文件名 [容器1]
.如果真 (取文本左邊 (名稱, 1) ≠ 「.」)
索引 = 遠程文件框.插入表項 (, 名稱, 1, , , 1)
遠程文件框.置標題 (索引, 2, 到文本 (文件時間 [容器1]))
.如果真結束 .如果真結束.計次循環尾 ()
' 填充文件
.計次循環首 (數目, 容器1)
.如果真 (位與 (文件屬性 [容器1], #子目錄) = 0)
索引 = 遠程文件框.插入表項 (, 文件名 [容器1], 2, , , 2)
遠程文件框.置標題 (索引, 1, 到文本 (文件尺寸 [容器1]))
遠程文件框.置標題 (索引, 2, 到文本 (文件時間 [容器1]))
.如果真結束.計次循環尾 ()

『貳』 易語言FTP上傳圖片怎麼上傳不上去

那你就把網頁跟圖片在一起上傳上去 網頁的站點你上傳對了嗎 你有沒有把圖片放在(管理站點)中 沒有就上傳不上去 FTP工具是一個上傳工具 當你在上傳圖片的時候要創建(管理站點)在管理站點中要輸入(自己申請的空間

『叄』 易語言連接Ftp伺服器後如何讀取某個圖片文件顯示在圖片框上

1、如果是FTP伺服器連接用以下代碼
.版本 2
.支持庫 internet

FTP文件下載 (「FTP伺服器上欲下載文件的路徑」, 「本地保存位置」, )
圖片框1.圖片 = 讀入文件 (「本地保存位置」)
2、如果是網頁圖片用以下代碼
圖片框1.圖片 = HTTP讀文件 (「HTTP文件地址」)

『肆』 易語言ftp上傳文件

[e=1].版本 2
.支持庫 spec

.子程序 _按鈕1_被單擊
.局部變數 ftp, 類_FTP

.如果真 (ftp.連接FTP伺服器 (地址, 帳號, 密碼, 21, ))
.如果真 (ftp.文件上傳 (取運行目錄 () + 「\123.txt」, 「/123.txt」, ))
調試輸出 (「上傳成功」)
.如果真結束

[/e]

1.文件上傳,返回的是真嗎。 是否上傳成功,如果成功了說明命令沒有問題,是參數的問題。

2.文件上傳的第二個參數,去掉IP地址試試。

『伍』 易語言,可以實現搜索電腦圖片一定大小,並傳到FTP空間,或者郵件傳送

辦法是有的,,,,,,
不過不是在這里能說清楚的代碼,,
真要做還要看 做這個東西值不值所付出

『陸』 易語言 圖片框如何打開FTP地址的圖片

HTTP讀文件不能用ftp下載,還有你確定你圖片地址對么?圖片地址如果在本機可以這樣直接寫路徑,但是在區域網其他機器上起碼也要用個iis開放個埠吧。開放埠後可以寫路徑,HTTP讀文件(http://「192.168.2.254:5355/20180612/圖片名稱.jpg」)

『柒』 怎麼用易語言讀取FTP裡面指定的文件

下載指定文件?

FTP文件下載 (, , )

需要先使用
連接FTP伺服器 (, , , , )
連接FTP伺服器。

『捌』 易語言FTP文件上傳問題,感激~

可以像圖片里寫。

其中FTP地址、賬號、密碼區你可以用編輯框來代替。其它的我就不多說了。

『玖』 易語言FTP連接

用一些FTP的軟體登錄可查看IP地址,軟體如:http://www.ote.com/soft/27925.html

『拾』 易語言ftp上傳後被佔用

看ftp伺服器命令中有沒有退出之類的