當前位置:首頁 » 數據倉庫 » 怎麼查看rip的配置
擴展閱讀
固態硬碟策略 2022-08-08 02:28:59
外存儲器種類有哪些 2022-08-08 02:26:40
硬碟時間查詢 2022-08-08 02:26:29

怎麼查看rip的配置

發布時間: 2022-08-06 13:09:04

1. 華為交換機配置好以後,用什麼命令查看以配置的信息。

華為交換、路由器常見命令

路由器基本配置命令舉例
[Quidway]sysname router_name 命名路由器(或交換機)
[Quidway]delete 刪除Flash ROM中的配置
[Quidway]save 將配置寫入Flash ROM
[Quidway]interface serial 0 進入介面配置模式
[Quidway]quit 退出介面模式到系統視圖
[Quidway]shutdown/undo shutdown 關閉/重啟介面
[Quidway]ip address ip_address subnet_mask 為介面配置IP地址和子網掩碼
[Quidway]display version 顯示VRP版本號
[Quidway]display current-configuration 顯示系統運行配置信息
[Quidway]display interfaces 顯示介面配置信息
[Quidway]display ip routing 顯示路由表
[Quidway]ping ip_address 測試網路連通性
[Quidway]tracert ip_address 測試數據包從主機到目的地所經過的網關
[Quidway]debug all 打開所有調試信息
[Quidway]undo debug all 關閉所有調試信息
[Quidway]info-center enable 開啟調試信息輸出功能
[Quidway]info-center console bugging 將調試信息輸出到PC
[Quidway]info-center monitor bugging 將調試信息輸出到Telnet終端或啞終端

換機配置命令舉例(大括弧{}中的選項為單選項,斜體字部分為參數值

[Quidway]super password password 修改特權模式口令
[Quidway]sysname switch_name 命名交換機(或路
[Quidway]interface ethernet 0/1 進入介面視圖
[Quidway]quit 退出系統視圖
[Quidway-Ethernet0/1]plex {half|full|auto} 配置介面雙工工
[Quidway-Ethernet0/1]speed {10|100|auto} 配置介面速率
[Quidway-Ethernet0/1]flow-control 開啟流控制
[Quidway-Ethernet0/1]mdi {across|normal|auto} 配置MDI/MDIX
[Quidway-Ethernet0/1]shutdown/undo shutdown 關閉/重啟埠

VLAN基本配置命令(以Quidway S3026為例) [Quidway]vlan 3 創建並進入VLAN配置模式,預設時系統將
所有埠加入VLAN 1,這個埠既不能被創建也不能被刪除。
[Quidway]undo vlan 3 刪除一個VLAN
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 給VLAN增加/刪除乙太網介面
[Quidway-Ethernet0/2]port access vlan 3 將本介面加入到指定VLAN id [Quidway-Ethernet0/2]port link-type {access|trunk|hybrid} 設置埠工作方式,access(預設)不支持802.1q幀的傳送,而trunk支持(用於Switch間互連),hybrid和trunk的區別在於 trunk
只允許預設VLAN的報文發送時不打標簽,而hybrid允許多個VLAN報文發送時不打標簽。

埠聚合配置命令
[Quidway]link-aggregation ethernet 0/7 to ethernet 0/10 {ingress|both} 配置埠聚合
Port_num1為埠聚合組的起始埠號,Port_num2為終止埠號
ingress為介面入負荷分擔方式,both為介面出負荷分擔方式。

STP基本配置命令
[Quidway]stp {enable|disable} 開啟/關閉 STP 功能,默認關閉,開啟後所有埠都參與STP 計算。
[Quidway-Ethernet0/3]stp disable 關閉指定介面上的STP功能,如某些網路不存在環路可以關閉STP。

PPP配置命令
[Quidway-Serial0]link-protocol ppp 封裝PPP協議
[Quidway-Serial0]ppp authentication-mode {pap|chap} 設置驗證類型
[Quidway]local-user username password {simple|cipher} password 配置用戶列表
- PAP驗證配置:
主驗證方
[Quidway]local-user username password {simple|cipher} password 配置用戶列表
[Quidway-Serial0]ppp authentication-mode pap
被驗證方
[Quidway-Serial0]ppp pap local-user username password {simple|cipher} password
- CHAP驗證配置:
主驗證方
[Quidway]local-user username password {simple|cipher} password 配置被驗證方用戶列表
[Quidway-Serial0]ppp chap host hostname 配置本地名稱
[Quidway-Serial0]ppp authentication-mode chap
被驗證方
[Quidway]local-user username password {simple|cipher} password 配置主驗證方用戶列表
[Quidway-Serial0]ppp chap user username 配置本地名稱

MP配置命令
[Quidway-Serial0]ppp mp 封裝MP協議
[Quidway]ppp mp user username bind virtual-template number 建立用戶與虛擬模板的對應關系
[Quidway]interface virtual-template number 配置虛擬介面模板
[Quidway]ppp mp max-bind number 設置虛擬模板最大綁定數(1-100)

幀中繼配置命令
[Quidway-Serial0]link-protocol fr {mfr|ietf|nonstandard} 封裝幀中繼協議:IETF、Cisco兼容
[Quidway-Serial0]fr interface-type {dte|dce|nni} 配置幀中繼介面類型,NNI為幀中繼交換機之間的介面。若配為DCE或NNI,則須先使能fr switching。
[Quidway-Serial0]fr lmi type {q933a|ansi|cisco-compatible} 配置LMI協議類型
[Quidway-Serial0]fr dlci dlci_number 配置一條本地虛電路號
[Quidway-Serial0]fr map {ip|ipx} protocol-address dlci dlci_number 建立本地DLCI到對端協議地址的映射
[Quidway-Serial0]fr inarp [ip|ipx] [dlci_number] 配置Inverse ARP動態映射
[Quidway]interface type number.subinterface_number 創建並進入子介面配置模式

RIP協議配置命令
[Quidway]display rip 顯示RIP配置信息
[Quidway]rip 啟動並進入RIP配置模式
[Quidway-rip]network {network_number|all} 在指定網路上使能RIP
[Quidway-rip]peer ip_address 配置報文的定點傳送
[Quidway-Ethernet0]rip version {1|2 [bcast|mcast]} 指定RIP版本及傳送方式
[Quidway-Serial0]rip work 指定介面工作狀態(同rip input,rip output)
[Quidway-rip]auto-summary 配置RIP-2路由聚合
[Quidway-Serial0]rip authentication simple password 配置RIP-2明文認證密碼
[Quidway-Serial0]rip authentication md5 key-string string 配置RIP-2 MD5密文認證密碼串
[Quidway-Serial0]rip authentication md5 type {nonstandard-compatible|usual} 指定MD5類型
[Quidway]debugging rip packet 打開RIP調試開關
[Quidway]info-center console 將調試信息輸出到PC

靜態路由配置命令
[Quidway]ip route ip_address subnet_mask {interface_name|gateway_address} [preference preference_value] [reject|black_bone]
[命令說明] reject:任何去往該目的地的報文均被丟棄,通知源主機不可達。
black_bone:任何去往該目的地的報文均被丟棄,不通知源主機。
當只有下一跳的介面是PPP或HDLC介面才能寫interface_name,如Serial0,否則只能寫gateway_address(下一跳地址)。
[命令舉例] [Quidway]ip route 129.1.0.0 16 10.0.0.2
[Quidway]ip route 129.1.0.0 255.255.0.0 10.0.0.2
[Quidway]ip route 129.1.0.0 16 Serial2
[Quidway]ip route 0.0.0.0 0.0.0.0 10.0.0.2 配置預設路由。

OSPF配置命令
[Quidway]router id ip_address 配置Router ID
[Quidway]ospf enable 啟用OSPF協議
[Quidway-Serial0]ospf enable area area_id 配置當前介面所屬的OSPF區域

2. 使用哪些命令可以驗證RIP路由配置情況

樓上回答的很對,show ip protocol :
Router#sh ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
//更新間隔,和下次更新時間
Sending updates every 30 seconds, next e in 22 seconds
//相關定時器
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
//RIP的發送和接受的版本:都是ver2
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Loopback0 2 2
//自動匯總被關閉
Automatic network summarization is not in effect
Maximum path: 4
//network了哪些網段
Routing for Networks:
1.0.0.0
12.0.0.0
Routing Information Sources:
Gateway Distance Last Update
12.1.1.2 120 00:00:09
Distance: (default is 120)

=====================
show ip route rip:這個是用來看通過rip學來的路由:
R2#sh ip route rip
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 12.1.1.1, 00:00:05, FastEthernet0/0

=========
如果樓主研究的深的話,還可以看rip的資料庫,命令如下:
R2#sh ip rip database
1.0.0.0/8 auto-summary
1.1.1.1/32
[1] via 12.1.1.1, 00:00:05, FastEthernet0/0
2.0.0.0/8 auto-summary
2.2.2.2/32 directly connected, Loopback0
12.0.0.0/8 auto-summary
12.1.1.0/24 directly connected, FastEthernet0/0
R2#

不知道樓主滿意否?

3. 請問rip路由協議配置的具體步驟是什麼謝謝

1、確定所要配置的網路組網及相關ip規劃,然後進行具體的配置。

4. RIP 1配置

樓主你好。
啟動RIP進程:router rip
宣告直連網段:network 1.1.1.1(示例)
查看路由協議配置:show ip protocol
使用版本2:version 2
關閉路由自動匯總:no auto-summary。
希望我的回答能幫到你,好運!

5. rip路由協議的配置命令

相關調試命令 :
show ip protocol
show ip route
在全局設置模式下:
1.啟動RIP路由
router rip
2.配置RIP路由協議的路由的子網
network 子網地址
3.允許在非廣播型網路中進行RIP路由廣播
neighbor 相鄰路由器相鄰埠的IP地址
4.配置RIP路由協議的版本
RIP路由協議有2個版本,在與其它廠商路由器相連時,注意版本要一致,預設狀態下,Cisco路由器接收RIP版本1和2的路由信息,但只發送版本1的路由信息,設置RIP的版本vesion 1或2.另外,還可以控制特定埠發送或接收特定版本的路由信息。

6. 如何查看自己本機原先配置的RIP是多少

Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback1
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback3

show ip route rip
show ip rip database

7. 如何看debug ip rip

debug ip rip命令顯示了發送和接收到的RIP路由選擇更新.
可以查看路由器使用了RIP的V1版還是V2版本.
還有發送和接收的更新信息.

和你分享一下我的CISCO基本命令集
CISCO基本命令集
show protocols
show mem
show ip route
show startup-config
show running-config
show flash
show interfaces
二、 基本路由配置命令
進入:config terminal/memory/network
配置網路時常採用的命令:和load
1. 標識:hostname 標識名
2. 啟動標識:banner 啟動標識
3. 介面:interface 埠號
4. 密碼:line 0 6
login
passwd 口令
enable password/secret 口令
5. 介面:
1)配置埠
interface 埠號
clock rate 時鍾速率(64000)/* 在串口中配置 */
bandwidth 帶寬(預設56) /* 在串口中配置 */
media-type 介質類型 /* 在乙太網口上 */
early-token release /* 在令牌環網口上 */
ring-speed 16 /* 在令牌環網口上 */
no shutdown
write memory
2)檢驗埠
show interfaces
show controllers
6. 配置環境
1) 引導方式
boot system flash IOS-filename
boot system tftp IOS-filename tftp-address
boot system rom
2) 配置Register值
config-register 0x2102
7. 查看鄰居路由
show cdp interface
show cdp neighbors [detail]
show cdp entry routerA
8. IP Address 配置
Ip address 網路地址 掩碼
Ip host 主機名 address
Ip name-se
rver 伺服器地址1 伺服器地址2 。。。
Ip domain-lookup nsap
Show hosts
Ping 主機名/IP地址
Trace 主機名/IP地址
三、 IP 路由
1. 靜態路由
ip routing
ip route 目標網路號 掩碼 埠號 [permanent]
2. 預設路由
ip default-network 網路號
3. 動態路由
1) RIP配置
Router rip
Network 網路號
Show ip route
Show ip protocol
Debug ip
2) OSPF 配置
Router ospf 進程號
Redistribute 其它路由協議
Network 埠網路 反掩碼 area 區域號
Area 區域號 range 網路號 掩碼
Area 區域號 default-cost 花銷值
Ip ospf priority number
Ip ospf cost 花銷值
Show ip ospf database
3) BGP 配置
Router bgp 自治域號
Redistribute 其它路由協議
Network 網路號 /* 自治域內 */
Aggregate-address 網路號 掩碼 summary-only 匯總網路
Neighbor 相鄰網路號 remote-as 自治域號 /* 自治域間的網路 */
四、 流量控制
1) 被動埠
passive interface 埠號
2) 預設路由
ip default 網路號/埠網路
3) 靜態路由
ip route 目標網路號 掩碼 埠號
4)ACL過濾表
(全局上) access-list 訪問號1 {permit|deny} 反掩碼號 [ established]
access-list 訪問號2 {permit|deny} IP/TCP協議 源網路 目的
網路
操作符 參數
(埠上)access-group 訪問號 in|out
distribute-list 訪問號 in|out 埠號
4) Null 0 interface
Ip route address mask null 0
五、 廣義網配置
1) PPP
Ppp pap sent-usename 封裝
Ppp chap hostname
Ppp chap password
2)X.25
encapsulation x25 [dce]
x25 address
x25 map 協議地址 /*SVC */
x25 pvc pvc號 ip地址 x25地址 /*PVC */
ip switching
x25 route x.121地址 介面 x.121映射地址
2) FrameRelay
Frame-relay local-dlci IP網路號
Frame-relay map 協議地址
Frame-relay lmi-type ansi

8. rip路由配置命令

1、創建RIP進程並進入RIP視圖
[Router] rip [ process-id ]
2、在指定網段介面上使能RIP
[Router-rip-1] network network-address [ wildcard-mask ]
3、配置介面工作在抑制狀態
[Router-rip-1] silent-interface { interface-type interface-number | all }
4、使能RIP水平分割功能
[Router-Ethernet1/0] rip split-horizon
5、使能RIP毒性逆轉功能
[Router-Ethernet1/0] rip poison-reverse
6、指定全局RIP版本
[Router-rip-1] version { 1 | 2 }
7、關閉RIPv2自動路由聚合功能
[Router-rip-1] undo summary
8、配置RIPv2報文的認證
[Router-Ethernet1/0] rip authentication-mode { md5 { rfc2082 { cipher cipher-string | plain plain-string } key-id | rfc2453 { cipher cipher-string | plain plain-string } } | simple { cipher cipher-string | plain plain-string } }